Jump to content

BramF

Members
  • Content Count

    12
  • Joined

  • Last visited

Everything posted by BramF

  1. Oil pressure and neutral light all word like they should. Usually the low fuel light would come on at 250km. I have gotten to this milage a few times recently but haven't dared to ride much further without fueling up, what should be a 'normal' range for the fuel light to turn on?
  2. So i checked the sensor wiring and it seem to be connected, also hooked up the multimeter which gave me a measurement of 1,600 ohm. Guess I'll have to keep looking/troubleshooting...😥
  3. Thank you all for the good suggestions Will investigate the fuel sensor connection this weekend and report back to you all.
  4. Is there any new info on a replacement for the fuel level switch? After taking my tank apart in order to get it painted it seems as the switch has given up. I've tried testing the fuel light by powering it directly and that lights it up nicely so I'm suspecting the fuel level switch of causing the fuel light to no longer work.
  5. It is true you are required to have a hi viz jacket with you in case of an emergency, you don't have to wear it whilst riding. The rules with regard to the reflective sticker only applies to helmets being sold in France, if you bring one from outside of the country it's no problem. Some other rules to keep in mind: - Riders and passengers are required to wear gloves (with a CE certification) - You need to have a breathalyzer with you - Your navigation isn’t allowed to have an option that gives a speed camera warning
  6. Had the same issue where the bike would lose power when turning the bars ('Stuur' for us dutchies ). In my case it was caused by a lose wire inside of the ignition switch similar to what Kiwi_roy discribes in his topic You could also check the bullet connectors near the front left of the frame that run to the clutch switch, as mentioned by Chuck. --EDIT-- Just found this older topic discussing how to check the bullet connectors, it could help you diagnose if the connectors are causing your issue
  7. Might be a relay thats stuck on, letting through electricity.
  8. That headlight bracket seems so wrong, and not in a good way. Do like the agressive stance created by the tank and seat, too bad the seatfairing doesn't flow as nicely as it does in the render.
  9. BramF

    BramF

×
×
  • Create New...