Jump to content

cash1000

Members
  • Content Count

    232
  • Joined

  • Last visited

  • Days Won

    6

Everything posted by cash1000

  1. Speedo behaved same way with both old & new speedo cable. So not so easy solution
  2. Fitted new Speedo cable the correct way around without the angle drive a few weeks ago Speedo back going again sort off Its back to its old habit of wildly swinging then settling down I think its only a matter of time before it dies completely I did find a repair kit on Ebay but clicking on sellers link caused computer to do the 'blue screen of death' Not good So be careful out there
  3. Any thoughts on how I'm going to repair the paint finish on my RM tank. Its bubbled next to the fuel tap. Only about 3-4 mm is visible when the tank if fitted I had a fuel leak from where the fuel tap connects to the tank. I've fixed that by replacing the o-ring (they are actually oval-rings) from local supplier as Guzzi agents in New Zealand had none. Make sure you get Viton ones which are impervious to petrol
  4. Great looking Rosso Mandello
  5. Done that. Its the Angle Drive that's broken. It didn't appear to be a month ago when I fitted new speedo cable. Must have been in process of failing Many thanks Doc for pointing me in right direction. Also found out I was fitting speedo cable the wrong way around Stumbled across fitting instructions when looking for new angle drive Moto Guzzi Angle Drive Replacement v11 SP 04768300-tlm gu04768300 gu047683 04 | eBay Yet to refit cable so fingers crossed it will solve speedo - tomorrow nights job
  6. I've just replaced speedo cable & run with & without angle drives & speedo still misbehaving (Posted a couple of weeks ago) But to eliminate possibility will disconnect speedo from speedo cable and run bike. If cable still turns its the speedo?
  7. I like the positive outlook
  8. Yes he didn't repair anything Mines done 72,000 k's approx
  9. Speedo finally died. Happened 10ks after leaving home on trip to Dunedin weekend before last It had been swinging wildly for a while so it was no surprise. Solution seems to be replace with new from Speedhut or get repalred. There is company called Parrots here in Christchurch that I know have repaired another V11 speedo with same problem. Can you get the parts to repair them yourself? I’ve found the video on youtube which gives some idea of what’s involved Motoguzzi V11 Sport Rosso Mandello 2001 Overhaul of speedometer and tachometer - YouTube Thoughts?
  10. Fitted new SBS front brake pads. One pad had nearly worn to the metal. Changed brake fluid at same time. Brakes feel good so far but still running in (200ks) Off to Dunedin this weekend (800ks return) so will know if I like them or not by end of trip
  11. Easy way to screw on cover is to turn it the wrong way until you hear the click as you get to the end of the threads on both cover and sump then turn correct way
  12. Fitted new fuel tap. Still need vice grips to open & close it About that offer Phil
  13. Fitted new speedo cable at weekend. One major problem Its to short If you fit it without the odometer gear it presses against the rod that links the 2 fuel injection units which affects the idle speed I ended up fitting the odometer gear which gave me to much length so I re-routed cable under the air box Worst of all it didn't fix the the crazy speedo. Anyone want a used speedo cable. Only done 70,000 ks?
  14. Taken Near Kaikoura on East Coast of South island New Zealand
  15. Latest 2 dogs - Storm 2 year old Cardigan Corgi & Raffa 4 year old Swedish Vallhund Raffa runs rings around Storm physically but Storm is the boss odd a
  16. I've always run 120/70 front & 170/60 rear on my RM 70k so about 10 sets. Front wears to a v and rear wears flat. I admit I don't wear the chicken strip out these days. Probably getting a bit old & slow
  17. Fitted new fuel tap. Finally got rid of persistent fuel smell V11 had. It never amounted to a leak. Also solved the problem of fuel tap being stiff to turn. Time will tell if this is a permanent fix.
  18. Strange how the body work has gone grey like its been left out side yet the rest looks great. Mine went that way but that's done over 70k
  19. Dipstick all fixed. See photo Many thanks to MartyNZ He drilled it penned it pinned it & epoxyed it I defy it to fall apart again
  20. Hi Marty many thanks for your kind offer. I will be in touch
  21. Went to check the oil level in VII and found stick had fallen off dipstick! Luckily it had jammed in Pete's surge plate rather than bounce around and cause damage This was the first thing I changed when I purchased the VII. Original plastic one was useless. Hard to read and differcult to screw in. Anyway I'm in the market for a new dipstick if anyone has one for sale
  22. Hi Phil. Many thanks for the offer. I've got a brother who is fitter & turner. Will see if he can follow your solution
  23. So for a non technical person could someone summarise what the solution is.
×
×
  • Create New...