Jump to content
Scud

What did you do to your V11 today?

Recommended Posts

18 minutes ago, Pressureangle said:

Odd, they appear in your response to me

Is access to the Google album in Google set to 'public'?

Share this post


Link to post
Share on other sites
6 hours ago, Admin Jaap said:

Is access to the Google album in Google set to 'public'?

Try that... Duh

 

Share this post


Link to post
Share on other sites

It was just a suggestion...

I think the problem is that your pictures don't have a valid extension, like .jpg or .png

Share this post


Link to post
Share on other sites
On 6/22/2019 at 4:01 PM, Mikko said:

'm thinking of a custom decal that goes over part of the standard "pure Michigan" propaganda and in the same color and font replace it with "oto Guzzi"

you should totally do that

Share this post


Link to post
Share on other sites

Yeah, I did it.

I put baby in a corner.....of her new garage!

4VwS9XM.jpg

  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites

Been a while. The V11 hasn’t gotten a lot of love this year. Rainy in the Midwest of the states here. The new to me T3 does my cycle errands and my suddenly unreliable 2t Yamaha has been getting my wrench time. Honestly though my best rides are on the V11. It just checks so many boxes.

Heres my whining though. I have (probably) gotten grease in the stupid front grease zerk before, but I finally found a sweet little 90deg grease gun attachment that snapped right on the zerk as easy as possible. A few grease pumps and for the life of me I couldn’t get the frickin thing off the zerk! Two hours!.... Finally I got serious, against my better judgement I pried it off with a screwdriver. Nothing broke I’m happy. I feel like atleast a few of us would appreciate the irony of eight years of trying to find a nozzle that fits and now I have to find one that also comes off.

No there are no adjustments on this attachment unfortunately.

  • Like 1

Share this post


Link to post
Share on other sites

No doubt your are the first :not: to have this happen. I believe it has to do with conjunction of the planets. They are aligned when the grease gun finally slips on.. then while pumping, one of them wobbles on it's orbit a bit.

  • Like 1
  • Haha 3

Share this post


Link to post
Share on other sites
3 hours ago, czakky said:

Been a while. The V11 hasn’t gotten a lot of love this year. Rainy in the Midwest of the states here. The new to me T3 does my cycle errands and my suddenly unreliable 2t Yamaha has been getting my wrench time. Honestly though my best rides are on the V11. It just checks so many boxes.

Heres my whining though. I have (probably) gotten grease in the stupid front grease zerk before, but I finally found a sweet little 90deg grease gun attachment that snapped right on the zerk as easy as possible. A few grease pumps and for the life of me I couldn’t get the frickin thing off the zerk! Two hours!.... Finally I got serious, against my better judgement I pried it off with a screwdriver. Nothing broke I’m happy. I feel like atleast a few of us would appreciate the irony of eight years of trying to find a nozzle that fits and now I have to find one that also comes off.

No there are no adjustments on this attachment unfortunately.

check this cz. worked well for me anyway. wheel off of course..

 

Share this post


Link to post
Share on other sites

I went with friends for a ride to a local airshow/carshow at Boundary Bay, near Vancouver.The traffic getting there was heavy and moving at a snail's pace. My Ballabio got hot and quit on me. I pulled over and tried to restart it but the starter would turn over once or twice and then just click. My buddy and I waited for the bike to cool down and tried a few more times before eventually bump starting it. It ran fine on the way home. I parked it and let it sit and tried starting it and she fired up no problems. Any ideas about the bike shutting down like that? Relays maybe? Also thanks to the fellow with the 2002 Le Mans who stopped by to give a hand. Are you on this forum?

Share this post


Link to post
Share on other sites

This sounds like a starting motor circuit problem . Loosen and retighten ALL battery , ground & starting motor connectors . You may have a battery problem also .

  • Like 1

Share this post


Link to post
Share on other sites

Agreed with gstallons about connections and checking the battery. Heat is hard on batteries. And the relays. With temps here in the US south at dangerous levels, the Sport knows she is not in the Alps. I moved an unstressed relay into the #2 postition and "think" *maybe* she was more forgiving on the way back home . . .

Make sure you are using Best Relays!

 

Share this post


Link to post
Share on other sites

Hey, thanks gstallons and docc for your replies. I will certainly look at all connections as recommended and I'm going to order some of those Omron relays. I see they still have a few hundred left. Thanks again guys! 

  • Like 1

Share this post


Link to post
Share on other sites

Dropped my rosso mandello today.  Amazingly, the only obvious damage was to the front turn signal (right), brake pedal, and head guard.  I have ordered head guard and brake pedal replacements from Joe on ebay, and I'm considering my options on the signal since I have a janky one on the rear of the bike too.  What else should I be looking for in terms of damage?  Bike seems to run fine, but it's parked until the brake pedal gets replaced.

Share this post


Link to post
Share on other sites

if the muffler hit the ground, the hangar bracket could bend. also bent foot peg. Joe has good stuff, thats what I have.

  • Like 2

Share this post


Link to post
Share on other sites

If your bike does not feature the additional transmission-frame bracket, look for possible oil leaks at the top mount of the gearbox.

This is how I cracked my transmission case, by dropping her...

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...