Jump to content
thumper

Voltage regulator

Recommended Posts

Just came back from a 80 mile run and checked my voltage at the battery.

At idle 13.2 volts at 4/5 thousand RPM 14.9 is that to high or am I OK

Thanks for the help

Share this post


Link to post
Share on other sites

I didn't freak out until I was at 17v+ while riding. :o

  • Haha 1

Share this post


Link to post
Share on other sites
3 hours ago, thumper said:

Just came back from a 80 mile run and checked my voltage at the battery.

At idle 13.2 volts at 4/5 thousand RPM 14.9 is that to high or am I OK

Thanks for the help

As long as you don't go over 14.9, you're golden.

  • Like 1

Share this post


Link to post
Share on other sites

Yep, Odyssey says not to exceed 15.0v. But I wonder what the condition of the battery was before the ride? (As in under, or well under the 12.65v Odyssey charging threshold) . . .

Also, you have added the regulator case-to-engine ground strap and have had a look at the condition of your green 30 amp fuse (for melting or signs of heat damage)?

Share this post


Link to post
Share on other sites

I own a 98 EV   behind the side cover operator side is a THING,it looks like regulator except 2/3 times larger,has about ten wires coming from it. on it is marked,Magneti Marelli   aei 450 B,can someone help me identify what this thing is? I will feel stupid later ,thanks!!!!

Share this post


Link to post
Share on other sites

Thank you Mr. Goose for your speedy reply! So, if thats the ECU what is the big square box(8")next to the battery,I thought that was the ECU!!! Please correct me,thank you.

Share this post


Link to post
Share on other sites

When you say "98 EV" are you talking about a California? Those have two CDI boxes. One mounted on the side, one by the battery. You can see them here:

http://www.harpermoto.com/parts-lookup/1990-1999-moto-guzzis/california-ev-v11-ev-usa-1100-1997-2001.html

 

The V11 Lemans don't use these. 

Share this post


Link to post
Share on other sites

I find this most confusing ---- but I guess I understand?--- the cdi is mounted to the ecu witch is next to the battery. Why didnt they abbreviate battery also??? Because 1cdi isnt enough th

ey installed #2 cdi behind the side plate,so you say,whats the problem? nothing here,I'm gonna have to get me a larger bottle of Bn(bourbon) too cope!!!! Thanks for your imput

  • Haha 3

Share this post


Link to post
Share on other sites
1 hour ago, fubar guzzi said:

I'm gonna have to get me a larger bottle of Bn(bourbon) too cope!!!!

lol ok... keep the shiny side up, bruv. 

Share this post


Link to post
Share on other sites

Written on my Odyssey ( as on probably every single one sold the last 20+ years) is 13,8V charging voltage for floating use. If you want to be nice to your battery you better keep the voltage in this range. If your 14.9 are real, then something's wrong with your charging circuit.

Only for those who drained theirs (in spec) it's below 14.8V, no inrush current limit.

Exide claims at least 40A/14.8V in case the battery shall fully recover from a deep discharge. If you take this serious you better don't drain it that deep (10 and less). 40x15=600W is a lot, maybe a charger for lorry batteries could come somewhat close.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...