Jump to content

Engine will not shutdown


Go to solution Solved by PeterT,

Recommended Posts

Hello,

For a few days now I have been able to turn off my ignition, but the engine continues to run, and voltage remains on all circuits. 
Is there anyone, who know's wat is wrong. Will this be a faulty relay or is there a leakage current somewhere? 
With the emergency stop, the motor will stop running, but the voltage remains on the circuits.

 If i remove 1 of the 3 large relays, the voltage will switch off, and if I then turn the relay back on, the voltage will remain in the circuit until I turn the ignition switch back on.

Thank you very much for thinking along!

Kind regards.

 

 

Link to post
Share on other sites
  • Replies 46
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I agree with the comments of previous contributors but, to me, the most revealing and interesting bit of information that would seem to help locate the problem is the rather odd phenomenon that the en

Thank you very much you nailed it!!!!! A view weeks ago i changed my throttle cable, to get there i had to loosen the brake lever slightly. When tightening, the cable has become trapped between th

The best way of thinking about what is happening is to think of the way you would arrange for a relay to latch itself ON and not turn off.  The way this is achieved is to connect up the contacts so th

Posted Images

39 minutes ago, Lucky Phil said:

Sound like the ignition switch contacts.

Ciao

Yes, or a (commonly found) broken wire at the Ignition Switch making contact where it should not.

Link to post
Share on other sites
4 minutes ago, docc said:

Yes, or a (commonly found) broken wire at the Ignition Switch making contact where it should not.

 

45 minutes ago, Lucky Phil said:

Sound like the ignition switch contacts.

Ciao

But if it is the Ignition switch, why does it turn of wenn i pullout the relays en put them back they stay off?

Link to post
Share on other sites

Good question! Sounds very much like what NicoNZ is experiencing. 
 

Has your bike been apart or worked on lately?

Link to post
Share on other sites
3 hours ago, docc said:

Good question! Sounds very much like what NicoNZ is experiencing. 
 

Has your bike been apart or worked on lately?

No, not lately:unsure:

I did pull out fuse 4, and this did resulted in the engine to stop.

If i turn de ignition switch on steeringlock or Parklight de engine keeps on running.

Link to post
Share on other sites

The ignition switch is not hard to remove from and disassemble to inspect (and repair if necessary).

 

Link to post
Share on other sites

I had another look, but it was not fuse 4 (ignition lock) but fuse 5 (lights (also 15 Amp)) that stopt the engine if I take it out:huh2:

if the engine is running, it only stops when I pull out one of the little relays. 

kind regards

Link to post
Share on other sites

Had another look today, replaced the relay, but that didn’t change anything. I have checked the battery connections, 3 on the massa and 5 on the positive pole. 
I did found out that wen I shut off the ignition switch, the blinkers and the small light in the hard light don’t work anymore. The main light hi and low still work, also the horn still works. 
If I turn of the engine with the kill switch, en I pull the clutch and then push the start button everything shuts down (so I don’t need to take of the seat anymore😋). 
 

Anybody any ideas left?

Link to post
Share on other sites

If the wires at the Ignition Switch are seen to be all intact at the solder joints, inspect for pinched or damaged wiring (as from a rodent chewing) and be certain the main ground to the gearbox is intact.

I will look again for images of the Ignition Switch fault.

  • Like 1
Link to post
Share on other sites

Okay, thanks again to Kiwi_Roy for documenting so many of these electrical issues for us!

And another:

Guzzi-Switch.jpg

  • Like 1
Link to post
Share on other sites
8 hours ago, gstallons said:

Are you able to kill the engine with the stop button on the bars ?

Yes, ik can stop the engine by the kill switch. And if the ignition switch is on off and i pull the clitch and push the start buton, the electrical circuit shuts down:wacko:.

If i dont push the start buton, the dashboardlights (Oil, batt and neutral) and de headlight (and the rearlight) remain on.

Link to post
Share on other sites

Which one of the large relays are you removing to stop the engine ? We will call the first relay from the front of the bike # 1 and the next one # 2 and so on........

 I reread your original post to verify this is exactly what is happening . Have you or anyone installed , modified or replaced anything on this bike ? How long has this been going on ?

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...