Jump to content
IGNORED

low pressure oil light on at idle


Go to solution Solved by mobetta,

Recommended Posts

What work has been done in the past ? Go back to when you did not have trouble . You will figure out what is wrong . 

  • Like 1
Link to post
Share on other sites

I had a problem like that with a 2003 LeMans. I hooked up an oil pressure gauge and found that the pressure was low. I finally solved it by dropping the oil pan, pump and spacer ring. Turns out piece of gasket was missing. New gasket - problem solved. But it had running like that for a while (since previous owner). On that bike, I ended up installing an aftermarket oil pressure gauge so I could monitor it instead of just having a warning light.

If you are not sure of the history, I'd recommend replacing those gaskets - and if you can get your hands on a Roper plate, that would be the time to install it.

  • Like 4
  • Thanks 2
Link to post
Share on other sites
On 4/17/2021 at 3:55 PM, docc said:

There have been instances of the old filter gasket staying on the motor when the filter came out.  Absolutely worth checking!

 

      That happened on my 2003 Lemans.

       I think that there are a lot of the V11's out there in the world like my bike; not many miles over the years, not many oil changes, and because the oil filter is a bit of a bear to get to and change, very few filter changes over their life time, it sets up the perfect storm for the gasket to come loose from the filter and get stuck in place, hidden somewhat out of sight.

       It was a bit of a head scratcher for me trying to figure out why the extra gasket was in place in my engine, it was only when I pulled the old filter out of the garbage to examine it closely, that I realized what was going on.

       Definitely something for all owners to keep in mind.

  • Thanks 2
Link to post
Share on other sites
  • Solution

As suspected pilot error on the oil pressure.

After dropping the pan and whole oil gallery/filter housing and spacer to get the bloody filter out, found old oil filter gasket still stuck in the oil filter housing. No proper seal no oil pressure. Will be more careful next time. Thx everyone for pointing me in right direction. Cheers

  • Like 6
  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...