Jump to content
IGNORED

Cutting out, redux


Recommended Posts

Cliff notes:  What’s the procedure for servicing the ignition switch?

My Sport has recently been cutting out, progressively getting worse. I’ve followed the recent thread addressing this problem and since I’ve been lifting the top triple multiple times for several bar changes, I thought the ignition switch would be the right place to start.  First time it cut out/stuttered  was after a right turn leaving my driveway. 

Looking at the switch in the picture, any tips on servicing it? TIA. 

https://postimg.cc/JtcF4YXm


 

 

 

Link to comment
Share on other sites

So, push in the white catch tabs all around to separate the switch. The contacts and wiring will reveal themselves.

 

  • Like 1
Link to comment
Share on other sites

Thanks Docc, the switch didn’t look bad, just a little worn at main contact. I need to finish mounting stock clipons and test ride it. Then on to the relay mounts if issue continues.

  • Like 1
Link to comment
Share on other sites

Well, the poor running continues.

And the winner is the relay contacts. After pulling out and reinserting all the relays it’s running well again. Time tomorrow to clean all the contacts and take for a longer shake down ride. Good for my lower back to be back on the stock bars. Thanks again to this forum and it’s members.

  • Like 2
Link to comment
Share on other sites

37 minutes ago, Bob Maynard said:

Well, the poor running continues.

And the winner is the relay contacts. After pulling out and reinserting all the relays it’s running well again. Time tomorrow to clean all the contacts and take for a longer shake down ride. Good for my lower back to be back on the stock bars. Thanks again to this forum and it’s members.

:thumbsup:

 

  • Like 2
Link to comment
Share on other sites

18 hours ago, Bob Maynard said:

Thanks Docc, the switch didn’t look bad, just a little worn at main contact. I need to finish mounting stock clipons and test ride it. Then on to the relay mounts if issue continues.

Bob, did you secure the wires coming out from the switch ?  IPA time here  :rasta:

Cheers tom 

  • Like 1
Link to comment
Share on other sites

No, they were zip tied for strain relief inside the black bottom cap of the switch and didn’t appear to need securing near the steering head. However, I did find a MG rubber cable tie on the floor while doing all the cable rerouting after handlebar removal.

https://postimg.cc/18Jf7qMh

88-F59029-7-EC1-4341-AA49-E2153159-E47-B

Any suggestions for placement?

Link to comment
Share on other sites

2 hours ago, Bob Maynard said:

No, they were zip tied for strain relief inside the black bottom cap of the switch and didn’t appear to need securing near the steering head. However, I did find a MG rubber cable tie on the floor while doing all the cable rerouting after handlebar removal.

88-F59029-7-EC1-4341-AA49-E2153159-E47-B

Any suggestions for placement?

Haha, well Moto Guzzi doesn't use many security ties for the harness and such. I see this little rubber tie on the clutch side to gather the various elements . . .

IMG_5235.jpg

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...