Jump to content
IGNORED

Voltage regulator??? 17+ volts!!!!


Junkyard
 Share

Recommended Posts

So I think my voltage regulator crapped out. Opinions??

Symptoms: Lights blinked brighter a couple times

riding along at steady throttle. Then just stayed that way.

When I checked the voltage at the battery later on I

got the normal 12-13V at idle but as I reved it up it climbed

nicely through 14, 15, 16, and I stopped at 17+.

So I'm thinking the voltage regulator, whatcha think

before I go spending $$. Though I really liked the brighter

headlight while I was riding at night. :D

Happy Saturday

Junkyard

Link to comment
Share on other sites

Yep, it is your voltage regulator.

Don't run it like this.

It will toast your ECU, wires, etc. :(

Check your 30Amp fuse for signs of melting.

Also, check the connection of the red/green wire coming from the regulator for oxidation, burning, melting, etc.

I replaced my regulator with an electrexusa single phase regulator.

It seems to work fine.

It produces better charging at idle.

At high RPMs it produces less voltage. This is better for the health of the electrical system, but old batteries may not recharge as well.

Combined with the proper battery charger and a Hawker Odyssey battery, I can recommend the Electrex regulator.

The ElectrexUSA regulator may work even better with a Yuasa battery because they spec a lower recharge voltage than the Hawker.

Others on the forum have recommended other regulators.

Some Harley ones can be made to work and can cost half as much money.

Here is my write up on the regulator

http://www.v11lemans.com/forums/index.php?showtopic=6828

Link to comment
Share on other sites

Yes, your regulator/recifier is done. It should allow no more than 13.8 volts back into the battery, for any 12 volt system. If your ECU doesn't frap first, you will cook your battery. I had one go on my Laverda. I replaced it with a Tymantium Voltpack. I have a multi use Boyer-Brandsen on another bike, both max output is 13.6 volts.

Ciao, Steve

Link to comment
Share on other sites

Yep, it is your voltage regulator.

Don't run it like this.

........snip......

Here is my write up on the regulator

http://www.v11lemans.com/forums/index.php?showtopic=6828

 

 

Thanks, That's what I thought just wanted to make sure.

I shut it down as soon as I aw the #'s on my voltmeter.

I'm amazed I didn'y fry something. I saw your write-up

on the Electrex. I may go that route, not sure.

Happy New years Eve everyone.

Junkyard

Link to comment
Share on other sites

Before you go out and blow your dough clean the mounting bolts between the regulator and the frame make sure there is good metal to metal contact as these provide the earth point for the regulator. Also check and clean the main battery earth lead where it bolts to the frame. If the reg looses its ground referance it does all sorts of odd things like 17 volts.

Link to comment
Share on other sites

  • 1 year later...
Yes, your regulator/recifier is done. It should allow no more than 13.8 volts back into the battery, for any 12 volt system. If your ECU doesn't frap first, you will cook your battery. I had one go on my Laverda. I replaced it with a Tymantium Voltpack. I have a multi use Boyer-Brandsen on another bike, both max output is 13.6 volts.

Ciao, Steve

It should allow no more than about 14.6V not 13.8 V. The manual says 14.0 to 14.6V is good.

But my Electrex puts out a little less than 14V...

Link to comment
Share on other sites

Before you go out and blow your dough clean the mounting bolts between the regulator and the frame make sure there is good metal to metal contact as these provide the earth point for the regulator. Also check and clean the main battery earth lead where it bolts to the frame. If the reg looses its ground referance it does all sorts of odd things like 17 volts.

Good points.

In retrospect my regulator and battery failing were probably caused by bad wiring, and it is possible my old regulator still works, if I rewire it.

I recall I had low voltage and likely had a bad connection between regulator and 30A fuse.

Hi voltage is more likely on the ground side.

Rev the engine up and get a long wire and run it from regulator body to negative ground of battery and see if the voltage drops below 14.6V.

Link to comment
Share on other sites

he David are you anwsering all old topics so they can be a case closed?

 

He's got some work to do :D

I hope Junkyard wasn't waiting for 17 months for that information.

Link to comment
Share on other sites

It should allow no more than about 14.6V not 13.8 V. The manual says 14.0 to 14.6V is good.

But my Electrex puts out a little less than 14V...

 

 

We shall agree to disagree. 14.6 is too much. But it's your bike not mine.

Steve

Link to comment
Share on other sites

From my recent regulator experience, I learnt this. The wires the goto the chargeing light, are used as voltage sensing by the regulator, so the voltage at the light goes down, it will compensate for that by charging at a higher voltage. So what can be noticed, is if you put the headlight on, the lights in the cockpit might dim. Then you should check it. What happend at my bike, there was a bad connection in the cabeling. When I put on the light, it draw the current so the charging light got only 9 volt, so the regutator did what it could to get it back at 13 volt, resulting at a battery voltage of 17 volt. I put a new loom in, and now I now have a pretty steady 14 volt voltage with or without light, measured over the battery terminals.

Link to comment
Share on other sites

he David are you anwsering all old topics so they can be a case closed?

No, because OldButNotDead linked here from a current case

http://www.v11lemans.com/forums/index.php?...st&p=145311

There seemed to be an indication that I solved my problem by replacing the regulator, but now I think it was wiring issues.

I just have to make sure the world knows how stupid I am for replacing a regulator that MAY be fine.

Thanks for helping reinforce that point...

From my recent regulator experience, I learnt this. The wires the goto the chargeing light, are used as voltage sensing by the regulator, so the voltage at the light goes down, it will compensate for that by charging at a higher voltage. So what can be noticed, is if you put the headlight on, the lights in the cockpit might dim. Then you should check it. What happend at my bike, there was a bad connection in the cabeling. When I put on the light, it draw the current so the charging light got only 9 volt, so the regutator did what it could to get it back at 13 volt, resulting at a battery voltage of 17 volt. I put a new loom in, and now I now have a pretty steady 14 volt voltage with or without light, measured over the battery terminals.

There is much that can go wrong along that line. One the early V11 the current must pass through a fuse and a couple relays.

Link to comment
Share on other sites

There is much that can go wrong along that line. One the early V11 the current must pass through a fuse and a couple relays.

 

Well before the v11, they had no fuse and guess what happens when there is an error in the regulator? It burns out completly. I have a sample here:-)

Link to comment
Share on other sites

From my recent regulator experience, ...snip... I put a new loom in, and now I now have a pretty steady 14 volt voltage with or without light, measured over the battery terminals.

 

 

Did you replace the entire wiring harnass (loom), or just a portion? I've been having some odd symptoms and am thinking it's time to try and sort them out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...