Jump to content
IGNORED

Neutral switch stays on after assembling shift plate


MartyNZ
 Share

Recommended Posts

3 hours ago, docc said:

After doing some work on my shift selector plate, my neutral switch is stuck on and I really don't want to go back in there.  :mellow:  (I sealed that cover REALLY WELL this time.) 

Did you wind the switch in to fix a leak? Try turning the neutral switch out 1/6 turn intervals until it works normally, then fit a seal washer of that thickness.  The switch turns on the green light when the plunger extends into a depression in the face of the lower cam wheel.

  • Thanks 1
Link to comment
Share on other sites

Nope, did not move the switch in the process.

So, the switch closes when the plunger at the tip has no contact (sits in the detent). This turns the light on (and pulls in the middle relay).

19207220_SWITCH.jpg

My switch tests good. The very slightest pressure on the plunger opens the switch (light out). I can see my detent lines up perfectly in neutral. The gearbox shifted perfectly today (notably better, even!) through all gears (205 miles) and clicks cleanly into neutral. All of the "Seeger rings" clipped onto the selector plate shafts.

It is as if the "toothed wheel" of the selector plate is too far from the switch to touch it, so it stays closed as if it were in the neutral detent.

I really don't want to open it back up. Worse, yet, I cannot fathom what could have changed . . .

IMG_5422.jpg

[edit: I tried installing the switch with no crush washer with no change. It does not appear to be touching the wheel. I also backed the switch out considerably and it stays closed, no pressure on the plunger. I had not removed the switch when the plate was removed for the sealing and roller bearing.]

Link to comment
Share on other sites

I can only suspect that the outboard flange of the lower cam wheel is against the pawl arm where that arm should seat in a groove between the inner and outer plates of the cam wheel.

I just would not think the seeger rings would capture on the shaft if that were the case . . .

And that the gearbox just would not shift well at all if it were jammed together like that. 

Link to comment
Share on other sites

Is it possible that the circlip (Item 13) (you call it a Seeger Ring) has come off, allowing the cam wheel to move inboard?

[docc edit July 30, 2021: added red emphasis to @MartyNZ's correct answer. Thanks,  :notworthy:  Marty!  ]

Or the nut holding item 20 post is not tight? That would allow both wheels to move inboard. (But only a tiny bit)

Gearbox Neutral.png.jpg

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

I tried to make sure the clips were seated in their grooves and spun them with a punch tip to verify.

Still, my plate has the "banana plate" that gets a second clip. (The other 13s in the upper right inset.)

The banana plate screw,  36, was really hard to remove and retighten, requiring heat. I wonder if that process backed out #20 lifting the assembly away from the switch plunger . . .

[edit: #20 looks nutted on the outside of the plate. Hard to imagine I loosened that.]

[edit2: that nut feels tight. No leaking around it.]

  • Like 1
Link to comment
Share on other sites

To me, the teeth of the lower cam wheel (that activates the neutral switch) look slightly "proud" of the upper cam wheel, especially on the forward aspect (right side in this view) where the neutral switch resides . .

Screen%20Shot%202021-07-24%20at%209.34.2

Enough to defeat the switch? Sumpin' ain't right . . . <_<

  • Like 1
Link to comment
Share on other sites

1 hour ago, docc said:

To me, the teeth of the lower cam wheel (that activates the neutral switch) look slightly "proud" of the upper cam wheel, especially on the forward aspect (right side in this view) where the neutral switch resides . .

Screen%20Shot%202021-07-24%20at%209.34.2

Enough to defeat the switch? Sumpin' ain't right . . . <_<

Yes docc there's an issue there. The gears should sit flush.

Like this. I magnified this image on  my computer and they are def flush as I remembered them to be.

gearbox mod 001.jpg

Ciao

 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Oh bummer... out she comes.

It's good you had the picture that shows the issue.

I think I've done at least 5 of these buggers. You really have to be careful about each retaining clip - that it is 100% seated. If the clip twists a bit and one end doesn't go in the groove, the whole clip will work its way out during operation. This is such a PITA part to get out, that it's worth making the preselector go through the full range of shifts several times before installation.

At least this is easier on a red-frame bike than a black-frame. :luigi:

  • Thanks 1
Link to comment
Share on other sites

A suggestion to try before you remove the side plate: push a screwdriver into the switch hole onto the cam plate. If you can feel the springiness of the banana plate bending, then it could mean the circlip is off.

  • Like 1
Link to comment
Share on other sites

6 hours ago, MartyNZ said:

A suggestion to try before you remove the side plate: push a screwdriver into the switch hole onto the cam plate. If you can feel the springiness of the banana plate bending, then it could mean the circlip is off.

Thanks for that. Yah, I slid a punch through the hole and rapped it with a wee ball pein hammer. Felt right solid, no play at all.

Thanks for the replies! Once back apart, I'll suss the issue and post.

  • Like 1
Link to comment
Share on other sites

On 7/24/2021 at 8:23 PM, MartyNZ said:

Is it possible that the circlip (Item 13) (you call it a Seeger Ring) has come off, allowing the cam wheel to move inboard?

[docc edit July 30, 2021: added red emphasis to @MartyNZ's correct answer. Thanks,  :notworthy:  Marty!  ]

So, yep, the lower cam wheel circlip had jumped it's groove allowing the wheel to move inboard against the "banana plate" where it would not actuate the Neutral Switch. Since it was against the plate retained by its own circlip, it felt solid pushing it or striking it with a punch through the switch hole. The circlip was retained on the shaft, so it wasn't going to drop off and get onto the gearbox.

I was leery of rotating the cam wheels on the bench as I knew they were in neutral (and marked them as  @Lucky Phil did) and didn't want to risk getting them out of synch with the gearbox.  Yet, as @Scud said:

On 7/24/2021 at 11:05 PM, Scud said:

I think I've done at least 5 of these buggers. You really have to be careful about each retaining clip - that it is 100% seated. If the clip twists a bit and one end doesn't go in the groove, the whole clip will work its way out during operation. This is such a PITA part to get out, that it's worth making the preselector go through the full range of shifts several times before installation.

Glad to have it sorted (checkride tomorrow).

Thank you all for your replies and encouragement. Thank you @MartyNZ (once again, I might add! :bier: )

Edited by docc
  • Like 2
Link to comment
Share on other sites

I actually shimmed the gear/ cam wheels inwards toward the gear shifting pins to improve engagement in the cam slots. With only 0.3mm clearance, this meant some fiddling with the neutral switch seal washer.

  • Like 2
Link to comment
Share on other sites

10 minutes ago, MartyNZ said:

I actually shimmed the gear/ cam wheels inwards toward the gear shifting pins to improve engagement in the cam slots. With only 0.3mm clearance, this meant some fiddling with the neutral switch seal washer.

Interesting. My gearbox shifted so much better after the (mis)assembly. I was surprised at the amount of axial play of the cam wheels on the shafts when I assembled it correctly. Tomorrow I'll find out if the shift improvement remains, or if it is better that the cam wheel(s) sit more inboard . . .

Link to comment
Share on other sites

4 hours ago, docc said:

Interesting. My gearbox shifted so much better after the (mis)assembly. I was surprised at the amount of axial play of the cam wheels on the shafts when I assembled it correctly. Tomorrow I'll find out if the shift improvement remains, or if it is better that the cam wheel(s) sit more inboard . . .

If it does shift better it's probably because it's allowed the shift cam/wheel to float a little on the shaft.  

Ciao

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...